Paul Zakharov (paul_z) wrote in ru_fedora_core,
Paul Zakharov
paul_z
ru_fedora_core

UpGrade to FC10, проблемы с зависимостями

Врдуг может поможет кто-нибудь...

Решил я тут обновится немного. И то верно - давно пора уж - поэтому обновляться я решил сразу с FC7 до FC10.

Ну... надо сказать, получилось конечно лучше чем у cgem - я у него в журнале вообще страшные вещи про 10-ку читал.

У меня оно хотя бы работает. Что наверное и не удивительно, с учетом того, что по моим представлениям оно на самом деле еще не 10... а где-то так, по серединке, а то и вовсе поближе к 7... что-то вроде 7.5

В общем апгрейдился примерно так (может какие-то промежуточные действия и пропустил, но по памяти вот самое основное).

yum update
yum clean all

rpm -Uvh ftp://download.fedora.redhat.com/pub/fedora/linux/releases/10/Fedora/x86_64/os/Packages/fedora-release-*.noarch.rpm

yum clean all
yum upgrade


Вот. Теперь она мне с гордостью заявляет, что она мол 10-ка.
И апгрейдов она много находит... да только ничего не апгрейдит.
Потому что на yum upgrade выдает следующее:

Error: Missing Dependency: libgnutls.so.13()(64bit) is needed by package vlc-core
Error: Missing Dependency: libImath.so.4()(64bit) is needed by package kdelibs4
Error: Missing Dependency: eclipse-rcp = 1:3.2.2-15.fc7 is needed by package eclipse-rcp-sdk
Error: Missing Dependency: libHalf.so.4()(64bit) is needed by package kdelibs4
[skip]
Error: totem-xine-mozplugin conflicts with totem
Error: Missing Dependency: eclipse-platform = 1:3.2.2-15.fc7 is needed by package eclipse-platform-sdk
Error: Missing Dependency: libmpcdec.so.3()(64bit) is needed by package vlc-core
Error: Missing Dependency: libIlmImf.so.4()(64bit) is needed by package kdelibs4
Error: Missing Dependency: libcucul.so.0()(64bit) is needed by package xine
Error: Missing Dependency: mono(gconf-sharp) = 2.16.0.0 is needed by package f-spot


"skip" - это я сам вставил, там еще строчек 20-ть примерно такого же.

И как с этим бороться?

Репозитории добавлять (RPMFusion) и убавлять (убрал livna да и вообще все, оставил только основной fc10). Количество строчек с Error, конечно, мняется, но в целом проблема остается.

Сейчас пробую плагинчик к yum --skip-broken - но кажется, что он не поможет.

Остается вариант попробовать снести все что вызывает проблемы, а потом его поставить заново. Хотелось бы понять насколько это правильный подход, тем более, что там кажется придется kdebase сносить, а оно за собой потянет еще кучу софта - так что я пока как-то не решаюсь.
Ну и плюс... некие непонятные вещи как f-spot - в списке установленных пакетов у меня вообще его нет.

Если кто-нибудь подскажет что-нибудь - заранее большое спасибо. :-)
  • Post a new comment

    Error

    default userpic
  • 9 comments